eclipse无法启动运行怎么解决?

阳光 2021-04-02 16:55:17 java常见问答 8241

eclipse作为java程序员的开发工具,很多人都喜欢使用它,因为它运行快,占据内存也比较小,但是最近有人使用它的时候,发现eclipse无法启动运行,不知道这要怎么解决了?下面来我们就来给大家讲解一下这方面的内容。

如果不能正常启动,通常有以下四种原因。

1.JDK未安装或环境配置不正确;

2.启动参数设置过大或过小;

3.JDK的版本过低;

4.eclipse的版本不符;

第一种情况,在命令行中输入 java -version 即可判断。如果正常显示JDK的版本信息,则说明安装正确;否则仔细检查下JDK的安装路径和环境变量的设置路径。

第二种情况,打开eclipse安装文件夹下有个Eclipse.ini的配置文件,里面的内容大概是:

-startup

plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar

--launcher.library

plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519

-product

org.eclipse.epp.package.jee.product

--launcher.XXMaxPermSize

256M

-showsplash

org.eclipse.platform

--launcher.XXMaxPermSize

256m

-vmargs

-Dosgi.requiredJavaVersion=1.5

-Xms40m

-Xmx512m

JVM初始分配的内存由-Xms指定,默认是物理内存的1/64;

JVM最大分配的内存由-Xmx指定,默认是物理内存的1/4。

默认空余堆内存小于40%时,JVM就会增大堆直到-Xmx的最大限制;

空余堆内存大于70%时,JVM会减少堆直到-Xms的最小限制。

因此,如果是第二种情况导致eclipse无法启动,我们只要将上述文件最后一行的 -Xmx512m 改成 -Xmx256m就行了。改完后,保存,然后再次启动一次Eclipse,看看问题是不是解决了。

第三种情况,eclipse的版本越高,所需要的JDK的版本可能也就越高,如eclipse 3.7的最低要求是JDK 1.5(建议下载1.6)。所以,重新安装一个高版本的JDK,并配置对应的环境变量,就可以使用了。

第四种情况,如果你电脑是32位的,那么最好下载32位的eclipse,并且JDK也是32位的;如果电脑是64位的,那么64位的eclipse显然是最佳选择。

如果出现eclipse无法启动运行的情况,可能就是以上这几种原因了,只要对症下药解决就可以了,但是上述四种方法都尝试过了,问题仍然没有解决,就只能重装系统了。最后大家如果想要了解更多其他工具教程知识,敬请关注奇Q工具网。

推荐阅读:

json文件怎么导入数据库?实例介绍

java怎么安装?java语言有哪些特点?

eclipse怎么保存java文件?如何导入java文件?